Bug #4719

Wouxun KG-UV8D PL/DPL Decode

Added by Phil Lichtenberger over 3 years ago. Updated 4 months ago.

Status:Feedback Start date:04/09/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Wouxun KG-UV8D

Description

Hi,
I've discovered an issue with Chirp and the Wouxun KG-UV8D. I'm using the "CHIRP daily-20170406" release at this time.

The issue was discovered when I tried to program in a channel that did not use PL/DPL Decoding. The radio still showed a "QT" on the display, which means that the channel required a decode tone. When I would manually enter the channel to edit it, the PL setting was set to none, and when I exited out, the "QT" was removed from the display.

I then wrote the FRS channels to the radio with no tone, and read it back with the Wouxun software. Wouxun's software shows an invalid tone is saved to the radio from Chirp. I then cleaned up the file and wrote it back to the radio and read it with CHIRP again. I've attached all files.

All FRS channels in the file should have no PL Decode tone, except for the memory channel that is labelled as having a tone.

Thanks

FRS Write.img - Writting FRS Channels to the Wouxon with no PL Decode (32 kB) Phil Lichtenberger, 04/09/2017 01:30 pm

FRS Read.img - Reading the CHIRP programmed radio that should have no PL Decode (32 kB) Phil Lichtenberger, 04/09/2017 01:30 pm

Read from Chirp.kg - Reading the CHIRP Programmed radio with Wouxun's Software (32 kB) Phil Lichtenberger, 04/09/2017 01:30 pm

Wouxun SW Fix.kg - Correcting the file with Wouxun's software so that no PL is required for Decode (32 kB) Phil Lichtenberger, 04/09/2017 01:30 pm

FRS Read after Wouxon Write.img - CHIRP reading the radio after being written by Wouxun's software (32 kB) Phil Lichtenberger, 04/09/2017 01:30 pm


Related issues

related to Bug #4425: KG-UV8D Inverted DCS Issue Feedback 01/18/2017
related to Bug #5483: Wouxun UV-8D download with DCS receive filter always on New 01/06/2018

History

Updated by Nathan Kennedy over 3 years ago

I am having this issue as well on the latest chirp daily build.

I would be happy to test any changes that would help fix this issue.

Updated by Bernhard Hailer 6 months ago

  • Status changed from New to Feedback
  • Target version set to chirp-daily
  • Chirp Version changed from 0.4.0 to daily
  • Platform changed from Windows to All

Is this still an issue with the current daily builds? Thanks.

Updated by John Leyendecker 4 months ago

Bernhard Hailer wrote:

Is this still an issue with the current daily builds? Thanks.

I'm using the latest version (20200622) and this is still a problem. In addition, if I use the factory software (which is horrible in most respects) to read the radio after writing with Chirp 20200622 the tones are all messed up. I went back to Chirp version 20190703 and the tones were correct in the radio and they were correct when I read the radio with the factory software.

I hope that helps

Also available in: Atom PDF

prevent spam