Bug #6653

Yaesu FT-7100M connection problem

Added by jason johnson over 1 year ago. Updated 6 days ago.

Status:Feedback Start date:03/30/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Yaesu FT-7100M

Description

Problem sending data to FT-7100M, I can download data from Radio to CHIRP, Unable to write data from PC to Radio. Using provided USB to Serial data cable. Radio does acknowledge the pressing of the REV button to start the Upload.

Radio displays error

PC Displays An error has Occurred

Failed to communicate with radio: Failed to read ACK. No response from radio.

Thank you for your support
V/r, Jason KB0EOD

debug.log (3.5 MB) Kevin Joyce, 03/05/2020 12:42 pm

chirp error message.PNG (32.3 kB) Kevin Joyce, 03/05/2020 12:42 pm

debug FT 7100.log (84.5 kB) Kevin Joyce, 03/05/2020 12:50 pm

debug.log (87.1 kB) K. Smyth, 05/07/2020 08:29 pm

error_msg_7100M_upload.tiff - error message displayed (29.8 kB) K. Smyth, 05/07/2020 08:29 pm

debug.log - ft-7100m fail to upload from CHIRP (84.5 kB) j graham, 07/04/2020 11:14 am

debug2.log (159.8 kB) j graham, 07/04/2020 11:14 am

debug.log - debug log (84.7 kB) Matt Sturtz, 09/16/2020 10:45 am

Chirp Home FT-7100.img - IMG file for this radio (7.9 kB) Matt Sturtz, 09/16/2020 10:45 am


Related issues

related to Bug #6641: Yaesu FT 7100 Feedback 03/24/2019

History

Updated by bill K7WXW about 1 year ago

I am also seeing this issue. Using Chirp, 081519 release, both mac (10.12.6) and windows (7), valley enterprises programming cable (FTDI) with latest drivers.

I am able to upload data from the FT7100M to Chirp.

On downloads to the FT7100M, after a pause of approximately five seconds, radio displays "ERROR", and there is a Chirp popup, "Failed to read ACK. No response from radio".

With the original, Yaesu supplied, Adams programming software, running in windows (7), FT7100M uploads and downloads work as expected. Have tried multiple versions of the file (empty, one entry, many entries, VHF only, UHF only) all with the same results: works with the Adams programming software, fails with Chirp.

Updated by Tony Fuller about 1 year ago

Hi Bill,

I don't have that radio but I'm interested in helping debug.

Could you post a debug.log file after opening chirp and attempting to upload?

https://chirp.danplanet.com/projects/chirp/wiki/How_to_report_issues#Getting-your-debug-log

Updated by Rick Brown about 1 year ago

I too have this exact problem. Has this problem been resolved or is there any work being done to debug it?
I can upload a debug report if you wish.
Rick.

Updated by Bernhard Hailer 7 months ago

  • Subject changed from FT-7100M to Yaesu FT-7100M connection problem
  • Status changed from New to Feedback
  • Priority changed from High to Normal
  • Target version set to chirp-daily
  • Model affected changed from (All models) to Yaesu FT-7100M
  • Platform changed from Windows to All

All submitters, please provide debug logs as described in the Wiki (How To Report Issues). Without it we can't help and will have to close the ticket.

Updated by Kevin Joyce 7 months ago

Hi Bernhard. Was this resolved? If not, here you go. I'm having the same problem.

Thanks,
Kevin
KM4FTE

Updated by Kevin Joyce 7 months ago

Kevin Joyce wrote:

Hi Bernhard. Was this resolved? If not, here you go. I'm having the same problem.

Thanks,
Kevin
KM4FTE

I attached the wrong debug file. Here's the correct version.

Updated by K. Smyth 5 months ago

same issue on both Win7 and MacOS

here is debug file from mac

Updated by Bernhard Hailer 5 months ago

The attached debug logs suggest that writing to the radio fails: the radio doesn't say that it heard anything.
This might be a cable, connector, or USB driver issue. Perhaps the following documents can provide some help?

CableGuide
CableGuide FTDI OEM Cables
RTSystemsCablesAndMavericks (if you're running MacOS)

Windows: If you are using a generic cable with a Prolific chip, you will very likely need to downgrade your driver to version 3.2.0.0.
It can be found at http://www.miklor.com/COM/UV_Drivers.php

MacOS: this OS is apparently very picky about USB to Serial cables. From what I heard, only (genuine) FTDI-based cables can be made work.

Updated by K. Smyth 4 months ago

Thanks for the update. I will go through the info.
I'm using an FTDI cable, and other cables from same supplier work OK on other radios with CHIRP on this computer. (running OSX 10.11.13)

Updated by Warren Billett 3 months ago

I am having the same issues and am wondering if the suggested solutions solved the issue?

Updated by j graham 3 months ago

jason johnson wrote:

Problem sending data to FT-7100M, I can download data from Radio to CHIRP, Unable to write data from PC to Radio. Using provided USB to Serial data cable. Radio does acknowledge the pressing of the REV button to start the Upload.

Radio displays error

PC Displays An error has Occurred

Failed to communicate with radio: Failed to read ACK. No response from radio.

This is my exact issue. per the last update by Bernhard, I downgraded the driver to 3.2.0.0 and confirmed this is currently in use. Attaching 2 logs.

WIN7

Thanks for any assistance!!

Updated by Matt Sturtz 6 days ago

Having the same issue. I'm using a Prolific USB cable that I know works, because I use the same cable for an FT-8800 which is working correctly in both directions.

Also available in: Atom PDF

prevent spam