Bug #7989

Support for Python 3

Added by Devyn Johnson 21 days ago. Updated 20 days ago.

Status:Closed Start date:06/16/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-py3
Chirp Version:daily Platform:All
Model affected:Python

Description

Chirp will need to update to Python3 at some point before it becomes deprecated. I cannot even install the Eoan package due to dependencies on packages that are no longer available in Focal (the Focal DEB package is not on the repository for some reason). I did see that a "py3" branch is available, but I have not checked to see if it is complete and workable. A PPA repository of the Python3 version of Chirp would be nice.


Related issues

duplicates Feature #495: PYTHON In Progress 02/03/2013
duplicates Feature #7431: Python3-friendly UI based on wxPython In Progress 12/09/2019

History

Updated by Bernhard Hailer 20 days ago

  • Status changed from New to Closed
  • Target version set to chirp-py3
  • Model affected changed from (All models) to Python

Duplicates #495 and #7431. Please follow and post there. Thanks.
Work to make Chirp operational under Python 3 is in progress.

Also available in: Atom PDF