Project

General

Profile

Actions

Bug #7989

closed

Support for Python 3

Added by Devyn Johnson almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/16/2020
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Python
Platform:
All
Debug Log:

Description

Chirp will need to update to Python3 at some point before it becomes deprecated. I cannot even install the Eoan package due to dependencies on packages that are no longer available in Focal (the Focal DEB package is not on the repository for some reason). I did see that a "py3" branch is available, but I have not checked to see if it is complete and workable. A PPA repository of the Python3 version of Chirp would be nice.


Related issues

Is duplicate of Feature #495: PYTHONClosed02/03/2013

Actions
Is duplicate of Feature #7431: Python3-friendly UI based on wxPythonClosedDan Smith12/03/2022

Actions
Actions #1

Updated by Bernhard Hailer almost 3 years ago

  • Status changed from New to Closed
  • Target version set to chirp-py3
  • Model affected changed from (All models) to Python

Duplicates #495 and #7431. Please follow and post there. Thanks.
Work to make Chirp operational under Python 3 is in progress.

Actions

Also available in: Atom PDF