Bug #8197

H-777 (as BF-888) failed to send to radio during upload (partial - stops at various locations) - downloads fine

Added by Greg Cotton 5 months ago. Updated 28 days ago.

Status:Closed Start date:08/22/2020
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:H-777/BF-888

Description

I recently purchased 6x Retevis H-777s in a kit from Amazon to expand a set we are already using at our church.
1) Upgraded my CHIRP to the 20200807 daily.
1a) Using a Baofeng Tech FTDI cable - same cable I've used for years to program these types of radios with CHIRP.
2) Used BF-888 profile in CHIRP (as previously, and still what is instructed for the H-777).
3) Downloaded CFG from radio -> no problems (I always do this to confirm connectivity to the radio via the cable).
4) Loaded the same CFG file I've been using for years (literally 2016) into CHIRP - reviewed settings (no changes needed)
5) When I tried to Upload to Radio, it stopped about halfway through with an "error failed to send block xxxx" message.
6) I could download from that same radio, and it was obvious that it had written part of the config - Channels 1-10 or so were the new config, but the rest were still the default config.
7) I repeated steps 2-6 on a second radio with similar results (the xxxx location where the upload stopped varied)

I found Bug #7607 while searching for a solution. During the discussion of that bug, they recommended downgrading CHIRP to a 2019 version. Unfortunately, that version wasn't on the CHIRP website, so I downgraded to a VERY old version that I had used previously "chirp-daily-20160717-installer.exe". This worked with no problems - I was able to upload the config to all 6 radios.

I've attached the CFG for reference, but I don't think there is anything strange with it.

Maybe related to Bug #7067 (sounds like similar symptoms, and fix was similar)

Baofeng_BF-888_DARING_Licensed_Freq-24Jul16.img - CFG file I tried to load. (992 Bytes) Greg Cotton, 08/22/2020 01:15 pm

Ansoko_A-8S_Factory_20200902.img - Original file image from radio (1.1 kB) Stan Pierson, 09/02/2020 10:28 am

Ansoko_A-8S_FRS_20200902.img - Modified image to FRS channels (1.1 kB) Stan Pierson, 09/02/2020 10:28 am

Retevis_H-777_(as_Baofeng_BF-888)_Default_Image_20200919.img - Default image for Retevis H-777 radios purchased Sep2020 (992 Bytes) Greg Cotton, 09/19/2020 11:16 am

debug.log (66.4 kB) David Christensen, 12/13/2020 04:54 pm

Retevis_H777_20201209.img (1.1 kB) David Christensen, 12/13/2020 04:56 pm

Baofeng_BF-888_20190905.img (1.1 kB) David Christensen, 12/13/2020 04:56 pm

debug.log (66.4 kB) David Christensen, 12/13/2020 04:56 pm

h777_reworked_timeout.py (19.4 kB) Jim Unroe, 12/17/2020 06:48 pm


Related issues

duplicated by Bug #8533: Retevis H-777 won't upload image Closed 12/09/2020

Associated revisions

Revision 3439:623665e53900
Added by Jim Unroe 29 days ago

[H777] Rework Serial Timeout

The previous patch has broken uploads for the classic BF-888s radios and
newer Retevis H777 models. The constanstant switching of the timeout to .5
before each block is sent and back to .25 after each block is sent on a
Windows computer creates "noise" that causes the apparently "faster"
radios to mis the "ack" returned by the radio which results in the upload
failing.

This patch resolves the issue by setting the serial timeout to .5 and leaving
it remain that way for all serial activity.

fixes #8197

History

Updated by Rudolph Gutzerhagen 5 months ago

It may be at step 4 where your problem starts. For the downloaded image from the new radio, modify that image, and then upload that one.
It looks like you attached your old image file that you used for years. If the above step correction does not work for you, attach a copy of the newly downloaded image as well, and the debug log related to the new radio. This will help someone to look at the details.

Updated by Stan Pierson 5 months ago

I have the same issue on Ansoko A-8S (BF-888S basis). I can load from the radio, but cannot upload a file to it.

I attached a file I loaded from a factory fresh radio (Ansoko_A-8S_Factory_20200902.img) then tried to upload it. The original image fails at block 20.

Changed the image to FSR channels. Same failure at a different block.

I tried 20200902 build, same results.

Updated by Greg Cotton 5 months ago

Rudolph Gutzerhagen wrote:

It may be at step 4 where your problem starts. For the downloaded image from the new radio, modify that image, and then upload that one.
It looks like you attached your old image file that you used for years. If the above step correction does not work for you, attach a copy of the newly downloaded image as well, and the debug log related to the new radio. This will help someone to look at the details.

Thanks for the tip. I failed to include it, but I did try that in my troubleshooting (download the config from a brand new radio w/ the 20200807 daily, and then try to re-upload to the same radio, and to a different radio). Unfortunately, it exhibited the same result - intermittent partial upload with a "failed to send block xxxx" message.

Unfortunately, I did not save the new image (and since I was able to get the radios re-imaged with the old CHIRP version, I can't re-download it). Sorry.

Updated by Greg Cotton 5 months ago

I've ordered more of the radios and I will test again. I will also upload the default image for your reference (hopefully this weekend).
Thanks for you help (and time and effort!) - this software really is amazing, and I would love to see it continue to be useful!

Updated by Greg Cotton 5 months ago

Greg Cotton wrote:

I've ordered more of the radios and I will test again. I will also upload the default image for your reference (hopefully this weekend).
Thanks for you help (and time and effort!) - this software really is amazing, and I would love to see it continue to be useful!

Quick question: Where do I get the debug logs?

Updated by Greg Cotton 4 months ago

Here is the default image from a new set of Retevis H-777 radios that I just recently purchased.

Updated by Bernhard Hailer 3 months ago

  • Status changed from New to Feedback

Quick question: Where do I get the debug logs?

Please see the Wiki: "How To Report Issues". Thanks!

Updated by David Christensen about 1 month ago

• Author: David Christensen
• Status: 8533 closed - added to this issue at their request
• Priority: Normal
• Assignee:
• Category:
• Target version:
• Chirp Version: daily
• Model affected: Retevis H-777
• Platform: Windows
The problems listed in issue #8197 are still present using the BF-888 Baofeng definition or the new Retevis H-777 profile. The radio will download fine but fails on upload at various places (Block 0000, 0028, etc.) There are a lot of these radios being sold. I successfully updated a set of radios in late 2019 but now it is broken. I tried the oldest archive (January 2020) and it fails also.
Thanks for the great work and I have gladly contributed financially in the past. Debug is attached as well as the old previously working image and a new image done by the new Chirp version.
73, Dave

Updated by David Christensen about 1 month ago

Two more files that didn't attach to my previous post for some reason

Updated by Jim Unroe about 1 month ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe

I just received a pair of H777 radios from Retevis. I have been able to reproduce this issue. I plan on investigating further so I can find a solution to the issue.

Jim KC9HI

Updated by Jim Unroe about 1 month ago

Please give this temporary test driver a try. It corrects the upload issue for the legacy BF-888s and newer Retevis H777 and H777 Plus models that I just received. Here is how you use it...

1 download the test driver module and save it to a convenient location
2 click "Help" in the CHIRP menu bar
3 enable "Enable Developer Functions"
4 click "File" in the CHIRP menu bar
5 click "Load Module" in the list that appeared
6 locate and load the test driver module that was saved in step 1

The CHIRP background will turn read to let you know that a custom driver module has been loaded. You can now test downloading/uploading to your radio.

Note 1: This test driver module does not permanently modify your CHIRP installation. It must be loaded every time you load CHIRP before you can download/upload from/to the radios that it supports.

Note 2: Do not right-click the custom driver module link to download it. You must left-click the custom driver module link and then click the "download" link on the following page that loads.

Let me know how this works and I will get a patch formally submitted.

Jim KC9HI

Updated by Jim Unroe 29 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Platform changed from Windows to All

No testers? Well it works for me so I made a patch and submitted it earlier today. Once approved the changes should be in the following CHIRP daily build.

Jim KC9HI

Updated by Anonymous 28 days ago

  • Status changed from Resolved to Closed

Applied in changeset 623665e53900.

Also available in: Atom PDF

prevent spam