Project

General

Profile

Actions

Bug #8245

closed

Kenwood TK-862 (NOT G) "Error setting memory: Frequency requires 12.50kHz step"

Added by Mike Smith over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/08/2020
Due date:
% Done:

100%

Estimated time:
Chirp Version:
daily
Model affected:
TK-862
Platform:
All

Description

I have Kenwood TK-862 (NOT G) and getting "Error setting memory: Frequency requires 12.50kHz step" when I go to program frequencies. I am entering frequencies used on the radios before so I know they are a supported step value. Any idea?

**Using CHIRP because the Kenwood software(KPG-29D) only runs on DOS.

Thanks


Files

KPG29D.txt (60 KB) KPG29D.txt David Le Grange, 11/17/2020 11:55 AM
Kenwood_TK-862_20200924.img (1.17 KB) Kenwood_TK-862_20200924.img Mike Smith, 11/19/2020 10:02 AM
tk760.py (27.4 KB) tk760.py test driver module to use while waiting for approval Jim Unroe, 02/23/2021 06:55 PM

Related issues

Related to Bug #8303: Kenwood TK-768 (N) "Error setting memory: Frequency requires 12.50kHz step"Feedback10/04/2020

Actions
Actions #1

Updated by Steve Allen about 2 years ago

Hi Mike. I run into the same issue trying to program a Tk-860. There were some other issues as well, but I did kludge a fix for the 12.5 thing. Only go three decimal places instead of the four. I've confirmed Chirp will take the tree and the radios seem to be okay with that. I'm guessing it's close enough to get through.

I haven't done any distance testing yet, but I'm using the Tk-860 as part of a complex repeater. For the short haul it is working. We'll see as I separate the distances.

I hope this helps.

Actions #2

Updated by Steve Allen about 2 years ago

Steve Allen wrote:

Hi Mike. I ran into the same issue trying to program a Tk-860. There were some other issues as well, but I did kludge a fix for the 12.5 thing. Only go three decimal places instead of the four. I've confirmed Chirp will take the three, and the radios seem to be okay with missing the last freq. digit. I'm guessing it's close enough in frequency to get through.

I haven't done any distance testing yet, but I'm using the Tk-860 as part of a simplex repeater. For the short haul it is working. We'll see as I separate the distances.

I hope this helps.

Actions #3

Updated by Jim Unroe about 2 years ago

  • Status changed from New to Feedback

The list of supported step values are not included in this radio's driver. When they are not listed, CHIRP uses a default step list that does not include the 6.25 or 12.5 steps. Do either of you know what the supported step values are for this radio?

Jim KC9HI

Actions #4

Updated by David Le Grange about 2 years ago

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

Actions #5

Updated by Jim Unroe about 2 years ago

David Le Grange wrote:

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

I know it needs the 12.5 step added. But I am looking for the complete list of valid steps supported by the radio. Maybe it is listed in the Kenwood programming software?

Jim

Actions #6

Updated by Jim Unroe about 2 years ago

Please attache a CHIRP Radio Images (*.img) file that can be used to test with.

Thanks,
Jim KC9HI

Actions #7

Updated by David Le Grange about 2 years ago

Hi Jim

I was looking in the KPG29D help file
I have attached the HELP file , im not finding what is required.

I have also E-mail it to you

Regards

David - ZR6DLG

Actions #8

Updated by Jim Unroe about 2 years ago

David Le Grange wrote:

Hi Jim

I was looking in the KPG29D help file
I have attached the HELP file , im not finding what is required.

I have also E-mail it to you

Regards

David - ZR6DLG

What I need is a CHIRP Radio Images (*.img) file so I can use it for testing. I have the coding done. I am unable to proceed due to a lack of being able to test.

Jim KC9HI

Actions #9

Updated by Jim Unroe about 2 years ago

David, Mike and Steve,

Would one (or all) of you please download from your radio, save it as a native CHIRP Radio Images (*.img) file and attach it to this issue so I can run tests on my patch.

Jim KC9HI

Actions #10

Updated by Mike Smith about 2 years ago

Hi Jim.
I hope this is what you are asking for.

Actions #11

Updated by Alex Radimor almost 2 years ago

Mike Smith wrote:

I have Kenwood TK-862 (NOT G) and getting "Error setting memory: Frequency requires 12.50kHz step" when I go to program frequencies. I am entering frequencies used on the radios before so I know they are a supported step value. Any idea?

**Using CHIRP because the Kenwood software(KPG-29D) only runs on DOS.

Thanks

Help i have kenwood tk-768 and I use ch340 module I use chirp but doesn't read from radio just on lcd appear -pc- I use dosbox dosent work module Ijust see unhandled

I'm very upset

Please help me wiring maybe i do wrong i dont understand with searching on internet have 6 pins

Please explain me pin 1 to 6 which pin must use with usb module ch340

Please please please help me

Actions #12

Updated by Alex Radimor almost 2 years ago

David Le Grange wrote:

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

Help i have kenwood tk-768 and I use ch340 module I use chirp but doesn't read from radio just on lcd appear -pc- I use dosbox dosent work module Ijust see unhandled

I'm very upset

Please help me wiring maybe i do wrong i dont understand with searching on internet have 6 pins

Please explain me pin 1 to 6 which pin must use with usb module ch340

Please please please help me

Actions #13

Updated by Alex Radimor almost 2 years ago

Jim Unroe wrote:

David Le Grange wrote:

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

I know it needs the 12.5 step added. But I am looking for the complete list of valid steps supported by the radio. Maybe it is listed in the Kenwood programming software?

Jim

Help i have kenwood tk-768 and I use ch340 module I use chirp but doesn't read from radio just on lcd appear -pc- I use dosbox dosent work module Ijust see unhandled

I'm very upset

Please help me wiring maybe i do wrong i dont understand with searching on internet have 6 pins

Please explain me pin 1 to 6 which pin must use with usb module ch340

Please please please help me

Actions #14

Updated by Alex Radimor almost 2 years ago

David Le Grange wrote:

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

Help i have kenwood tk-768 and I use ch340 module I use chirp but doesn't read from radio just on lcd appear -pc- I use dosbox dosent work module Ijust see unhandled

I'm very upset

Please help me wiring maybe i do wrong i dont understand with searching on internet have 6 pins

Please explain me pin 1 to 6 which pin must use with usb module ch340

Please please please help me

My email is babaktavvana@gmail.com

73

Actions #15

Updated by Alex Radimor almost 2 years ago

David Le Grange wrote:

Hi all
I do believe that the 768, 862, and similar are 12,5 steps.

One other thing that I am in South Africa IARU Region 1 UHF and the Frequency allocation for our UHF
starts at 430 Mhz and ends at 440 Mhz.

ZR6DLG

Help i have kenwood tk-768 and I use ch340 module I use chirp but doesn't read from radio just on lcd appear -pc- I use dosbox dosent work module Ijust see unhandled

I'm very upset

Please help me wiring maybe i do wrong i dont understand with searching on internet have 6 pins

Please explain me pin 1 to 6 which pin must use with usb module ch340

Please please please help me

My email is babaktavvana@gmail.com

73

Actions #16

Updated by Jim Unroe almost 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-daily
  • Platform changed from Windows to All

I think I can resolve this with the information that I was provided and used for the "G" models.

Jim KC9HI

Actions #17

Updated by Jim Unroe almost 2 years ago

  • File tk760.py tk760.py added
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

A patch has been submitted that adds the missing valid_tuning_steps list to support 6.25 KHz and 12.50 KHz steps.

A temporary test driver module has been added to this issue. It can be loaded while CHIRP has "Enable Developer Mode" enabled so the added steps can be used while waiting for the patches to be approved and added to the CHIRP daily build.

Note: You must left-click the file and then click "Download" on the page that loads. Do not right-click to download.

Jim KC9HI

Actions #18

Updated by Anonymous almost 2 years ago

  • Status changed from Resolved to Closed

Applied in changeset commit:dc7a285570cb.

Actions

Also available in: Atom PDF