Bug #6567

Error reading Baofeng UV-6

Added by Mikhail D over 1 year ago. Updated 21 days ago.

Status:Closed Start date:03/05/2019
Priority:Normal Due date:
Assignee:Jim Unroe % Done:

100%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:All
Model affected:Baofeng UV-6

Description

I can't read the radio. at the end of the running strip I receive an error message - "Radio refused to send second block 0x1ec0"
At the same time UV-82, BF-888 work normally

debug.log - CHIRP debug log (39.6 kB) James L, 03/10/2019 07:18 am

label.jpg - UV-6 radio label (111.5 kB) James L, 03/10/2019 07:18 am

Baofeng_UV-6_20200826.img (6.2 kB) Bryan Hatton, 08/26/2020 07:16 pm

uv5r_uv-6_test1.py (65 kB) Jim Unroe, 08/29/2020 07:04 pm

error.JPG - error UV-6 (21.8 kB) Mikhail D, 08/30/2020 09:38 pm

uv5r_uv-6_test5.py (63.2 kB) Jim Unroe, 08/31/2020 05:06 am

uv5r_uv-6_test6.py (63.3 kB) Jim Unroe, 08/31/2020 02:47 pm


Related issues

related to New Model #6447: Zastone ZT-889G and uv-6 Closed 02/14/2019
related to Bug #7115: Baofeng UV-5R "Radio refused to send block 0x0000" Closed 09/23/2019
duplicated by Bug #5905: Baofeng UV-6 Firmware Closed 06/18/2018
duplicated by Bug #5887: Baofeng UV-6 Firmware Closed 06/18/2018
duplicated by Bug #5615: UV-6 cannot download settings Closed 02/28/2018
duplicated by Bug #6173: Baofeng UV-6, error in Download from Radio function Closed 10/18/2018
duplicated by Bug #5181: UV-82 reading problems with chirp-daily-20170714 Closed 09/21/2017

Associated revisions

Revision 3402:fb0e42bb94ed
Added by Jim Unroe 22 days ago

[UV-6] Support Baofeng UV-6 without Auxiliary Block

This patch adds support for Baofeng radio models, including the UV-6,
that do not support access to the auxiliary block of memory.

Fixes #6567

History

Updated by James L over 1 year ago

Same error. When reading newly purchased Baofeng UV-6 I receive an error at the end "Radio refused to send second block 0x1ec0." The radio succesfully reads/writes when using the official Baofeng UV6UV7_CPS software, http://www.baofengradio.com/endownload.asp?BigClassName=Programming%20Software&SmallClassName=&page=3.

I am using Windows 10, CHIRP daily-20190307, BaofengTech FTDI programming cable. I have 4 of these radios and have the same issue when reading from all of them. I am able to successfully read/write to my Baofeng UV-5R. The radio has 2 CMIT IDs on the back: 2012FP1944 and 2017FP2640.

Thanks.

Updated by Carlos Marquez about 1 year ago

I just got a new UV-6 and have same problem. My old UV-6 downloaded but only the memories tab was populated with info.

Updated by Carlos Marquez about 1 year ago

Same as Bugs #5615, #6173, #5905, #5887, #6447.
It's been a while since I have contributed. Let me know what you need. Seems like there was a port monitor program that you needed the output from.

Updated by Mikhail D about 1 year ago

I would like it to work. Tell me what can I give? What should I do?

Updated by Jim Unroe about 1 year ago

  • Status changed from New to Feedback

These radios are refusing to return the second part of the radio's firmware section of memory. CHIRP needs/uses this information to be able to adjust for the radio being programmed.

Jim KC9HI

Updated by Thiago Victor 8 months ago

Radio presenting the same problem, does anyone have a solution?

"Radio refused to send second block 0x1ec0."

Updated by Pino Digiuseppe 8 months ago

Baofeng UV-6 always the same error "Radio refused to send second block 0x1ec0". Is perfectly working with the UV-6 UV-7 Baofeng software. But I need for Chirp. Please!

Updated by Bernhard Hailer 4 months ago

  • Status changed from Feedback to Rejected

I believe what Jim meant was "there's not much we can do, sorry". :-(

Updated by Bryan Hatton 27 days ago

Jim Unroe wrote:

These radios are refusing to return the second part of the radio's firmware section of memory. CHIRP needs/uses this information to be able to adjust for the radio being programmed.

Jim KC9HI

I don't think this is the case.

I looked at the serial communication from chirp and compared to the software from baofeng.

I believe the problem is that chirp asks for the firmware twice.

The first time it asks at the beginning of the transaction it receives the firmware.

after receiving the channel information, the device sends 2 NULLs (I believe this is to hang up.) I think the logic of uv5r.py needs some updating.

Updated by Bryan Hatton 27 days ago

The problem is not with the firmware.

I commented out these following lines in uv5r.py

LOG.debug("downloading aux block...")
  1. Auxiliary block starts at 0x1ECO (?)
    for i in range(0x1EC0, 0x2000, 0x40):
    data += _read_block(radio, i, 0x40, False)

and it works!!!

so ummm.... I think the UV-6 doesn't have any Aux blocks. so that was the problem. Just guessing tho.

I've not tried writing to it yet.

I believe the correct solution in to put a if statement in the code so if it is a UV-6 you don't try to download the AUX block.

Updated by Jim Unroe 27 days ago

Bryan Hatton wrote:

The problem is not with the firmware.

I commented out these following lines in uv5r.py

LOG.debug("downloading aux block...")
  1. Auxiliary block starts at 0x1ECO (?)
    for i in range(0x1EC0, 0x2000, 0x40):
    data += _read_block(radio, i, 0x40, False)

and it works!!!

so ummm.... I think the UV-6 doesn't have any Aux blocks. so that was the problem. Just guessing tho.

I've not tried writing to it yet.

I believe the correct solution in to put a if statement in the code so if it is a UV-6 you don't try to download the AUX block.

Actually the UV-6 that the driver was created with does have the AUX blocks. So it is a little more complicated than disabling the Auxiliary Blocks section of code for everybody. All the settings that get their data from the AUX block would have to be disabled as well. Please attach a image created from your radio using the patched driver so it can be examined.

Jim KC9HI

Updated by Bryan Hatton 27 days ago

Jim Unroe wrote:
Please attach a image created from your radio using the patched driver so it can be examined.

Jim KC9HI

here you go.

Updated by Bryan Hatton 27 days ago

I have the serial traffic of both chirp and the manufactures program if that would be of any help.

Updated by Jim Unroe 24 days ago

  • Status changed from Rejected to In Progress
  • Assignee set to Jim Unroe

Bryan Hatton wrote:

Jim Unroe wrote:
Please attach a image created from your radio using the patched driver so it can be examined.

Jim KC9HI

here you go.

Bryan,

Thanks for the image. Let's see if I can come up with something.

Jim KC9HI

Updated by Jim Unroe 24 days ago

Please test this custom driver module to see if it works for a Baofeng UV-6 that does not support Aux Memory. If you also have other Baofeng UV-5R like models (UV-5R, BF-F8HP, UV-82, UV-82HP, etc), test a few of them to make sure that their support is not broken. Then provide feedback.

Here is how you use the custom driver module.
1 save custom driver module to a convenient location (Do not right-click link. Click link and choose "Download" on the following page that appears. )
2 click "Help"
3 enable "Enable Developer Functions"
4 click "File"
5 click "Load Module"
6 locate and load custom driver module that was saved in step 1

The CHIRP background will now be red to indicate it is running with a custom driver module loaded. You can now test the custom driver module.

Note: The test driver module does not permanently change your CHIRP installation in any way. Every time you load CHIRP you must load this driver module to continue testing.

Jim KC9HI

Updated by Bryan Hatton 23 days ago

So it works with my uv-6 and my uv-82hp

(what stuff in saved in the aux?) so I can better test it.

Bryan

Updated by Bryan Hatton 23 days ago

here are the only things I have noticed tonight,

1. on the uv-6 under duplex if you select off (to make a listen only channel) it still transmits. I think this is a limitation of the radio.

2. the following error is produced during the upload (how ever it works fine):
ERROR: Clone failed: Upload finished, but the 'Other Settings' could not be sent because the firmware version of the image () does not match that of the radio (�������UV6H011).

3. chirp adds functionality that the manufacturers program doesn't have, it allows 7 char name instead of 6 :-)

I've not seen any issues with my uv-82hp.

Bryan

Updated by Mikhail D 23 days ago

Jim Unroe wrote:

Please test this custom driver module to see if it works for a Baofeng UV-6 that does not support Aux Memory. If you also have other Baofeng UV-5R like models (UV-5R, BF-F8HP, UV-82, UV-82HP, etc), test a few of them to make sure that their support is not broken. Then provide feedback.

Here is how you use the custom driver module.
1 save custom driver module to a convenient location (Do not right-click link. Click link and choose "Download" on the following page that appears. )
2 click "Help"
3 enable "Enable Developer Functions"
4 click "File"
5 click "Load Module"
6 locate and load custom driver module that was saved in step 1

The CHIRP background will now be red to indicate it is running with a custom driver module loaded. You can now test the custom driver module.

Note: The test driver module does not permanently change your CHIRP installation in any way. Every time you load CHIRP you must load this driver module to continue testing.

Jim KC9HI

It turned out to read the radios uv-6 and uv-82. I am not very good with the full testing program. Thank.

Updated by Jim Unroe 23 days ago

Testing would be to check to see that all of the UV-82 settings still appear and both radios can (still) download/upload. Also make sure that and "image" from each radio can be saved and restored.

Jim KC9HI

Updated by Mikhail D 22 days ago

Jim Unroe wrote:

Testing would be to check to see that all of the UV-82 settings still appear and both radios can (still) download/upload. Also make sure that and "image" from each radio can be saved and restored.

Jim KC9HI

when loading in uv-6 error in the screenshot. with uv-82 everything is fine.

Updated by Mikhail D 22 days ago

when loading in uv-6 error in the screenshot, while the data was loaded and read. with uv-82 everything is fine.

Updated by Jim Unroe 22 days ago

Mikhail D wrote:

when loading in uv-6 error in the screenshot, while the data was loaded and read. with uv-82 everything is fine.

This was discovered by another tester. It is more of a notification than it is an error. The upload itself is successful.

In any case, we did some additional testing and I got a report overnight that this "test5" driver module suppresses the notification.

Jim KC9HI

Updated by Jim Unroe 22 days ago

This version, test6, updates the code making it easier to implement support for additional radio models that do not share their Aux Block with CHIRP. If testing reveals that "test6" works for the UV-6 without breaking other radio models, it should be what I submit.

Jim KC9HI

Updated by Anonymous 21 days ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Applied in changeset fb0e42bb94ed.

Also available in: Atom PDF

prevent spam