Bug #7859

Python2 EOL prevents installation/running Chirp

Added by mike wigley 20 days ago. Updated 2 days ago.

Status:Closed Start date:05/07/2020
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:(All models)

Description

With installation of Fedora32, Python2 libraries are removed and Chirp will no longer install or run directly from uncompressed tar file. Is there a workaround or will Chirp move to py3?


Related issues

duplicates Feature #495: PYTHON In Progress 02/03/2013
duplicates Feature #7431: Python3-friendly UI based on wxPython In Progress 12/09/2019

History

Updated by Bernhard Hailer 19 days ago

  • Status changed from New to Closed
  • Priority changed from Immediate to Normal
  • Target version set to chirp-daily

This is a problem the Chirp team is well aware of. A lot of Linux distributions are on similar paths right now.
Having said that, we can't work on that "immediately", it's a major undertaking. Please be patient with us.
See tickets #495, #7431. Please leave any comments you might have on these tickets. Thanks!

Updated by Tony Fuller 16 days ago

There is a workaround in the meantime and we'd love some feedback. We are investigating using flatpak as a crutch until CHIRP is fully migrated to python3.

First you'll need flatpak:
https://www.flatpak.org/setup/Fedora/

Now that flatpak is all set up try out this flatpak by Richard Shaw

curl -LO https://hobbes1069.fedorapeople.org/chirp-20200430.flatpak
flatpak uninstall chirp
flatpak install chirp-20200430.flatpak

If you already had flatpak installed, you'll immediately notice a CHIRP icon in your programs list.
If you just installed flatpak, log out and log back in to see the new CHIRP icon in your programs list.

Updated by Kevin Becker 2 days ago

This flatpak is mostly working for me on Fedora 32 on my Baofeng UV-5R. I'm able to load and save configs to/from the radio. However, when attempting to import from RepeaterBook the cursor just spins forever. I've tried it on two different F32 machines with the same result. RepeaterBook imports are working from my Mac on the same network.

Also available in: Atom PDF