Bug #6747

Retevis RT22 New firmware "Radio Identification Failed"

Added by Jacob Clark over 1 year ago. Updated 3 days ago.

Status:Feedback Start date:04/26/2019
Priority:Normal Due date:
Assignee:- % Done:


Target version:chirp-daily
Chirp Version:daily Platform:Windows
Model affected:Retevis RT22


Retevis released an updated RT22 model, mine just happens to be Camo. When trying to Download or Upload to the radio I am getting a "Radio Identification Failed" error, even had someone else try it on their computer. Any ideas on how to fix it?

debug.log (24.1 kB) YCAH Technical, 10/18/2019 11:08 am

Annotation 2019-12-11 110715.jpg - screen grab (123.8 kB) Luke Cunnien, 12/11/2019 09:08 am

rt22-new-id.patch - patch adding ID for new RT22 (408 Bytes) Vladimir Kondratiev, 01/07/2020 01:24 pm

Retevis_RT22_new_factory.img - factory image for new RT22 (1.2 kB) Vladimir Kondratiev, 01/07/2020 01:24 pm

retevis_rt22_butchered.py (19.4 kB) Dan OLeary, 06/09/2020 09:14 pm

Related issues

duplicated by Bug #6315: "Radio Identification Failed" || Luiton LT-316 Closed 12/21/2018
duplicated by Bug #6757: problem reading data from WLN KD-C1 - Radio identificatio... Feedback 04/27/2019
duplicated by Bug #6803: WLN KD-C1 radio identification failed Closed 05/21/2019
duplicated by Bug #6989: Radio Identification failed error Closed 08/16/2019
duplicated by Bug #7091: Luiton LT316 3W will no longer program Feedback 09/18/2019
duplicated by Bug #7827: Radio identification failed Closed 04/24/2020
duplicated by Bug #7847: CHIRP won't download from WLN KD-C1 Closed 04/30/2020


Updated by Jim Unroe over 1 year ago

  • Status changed from New to Feedback

Does the original factory software still work.

Please attach a debug.log file so it can be examined.


Updated by Corey Nakayama 11 months ago

Factory software works on Camo RT22.

Updated by YCAH Technical 10 months ago

I'm having the exact same issue with the same model, a brand new RT22 (happens to be the camo color also).

Here's the relevant part from the debug.log file. I'll upload the entire file as well.

[2019-10-18 10:58:53,121] chirp.ui.reporting - DEBUG: Checking for updates
[2019-10-18 10:58:53,272] chirp.ui.reporting - DEBUG: Server reports version daily-20191018 is latest
[2019-10-18 10:58:59,237] chirp.ui.mainapp - DEBUG: User selected Retevis RT22 on port COM4
[2019-10-18 10:58:59,364] chirp.ui.clone - DEBUG: Clone thread started
[2019-10-18 10:58:59,364] chirp.drivers.retevis_rt22 - DEBUG: download
[2019-10-18 10:58:59,418] chirp.drivers.retevis_rt22 - DEBUG: Incorrect model ID, got this:

000: 50 33 32 30 37 21 f8 ff P3207!..

[2019-10-18 10:58:59,420] chirp.ui.reporting - DEBUG: Reporting exception
[2019-10-18 10:58:59,420] chirp.ui.common - ERROR: -- Exception: --
[2019-10-18 10:58:59,421] chirp.ui.common - ERROR: Traceback (most recent call last):
File "chirp\ui\clone.pyo", line 256, in run
File "chirp\drivers\retevis_rt22.pyo", line 331, in sync_in
File "chirp\drivers\retevis_rt22.pyo", line 230, in do_download
File "chirp\drivers\retevis_rt22.pyo", line 139, in _rt22_enter_programming_mode
RadioError: Radio identification failed.

[2019-10-18 10:58:59,421] chirp.ui.common - ERROR: ----------------
[2019-10-18 10:58:59,421] chirp.ui.clone - ERROR: Clone failed: Radio identification failed.
[2019-10-18 10:58:59,464] chirp.ui.clone - DEBUG: Clone thread ended
[2019-10-18 10:58:59,466] chirp.ui.reporting - DEBUG: Reporting model usage: Retevis_RT22,download,True
[2019-10-18 10:58:59,467] chirp.ui.reporting - DEBUG: Reporting exception
[2019-10-18 10:58:59,467] chirp.ui.inputdialog - ERROR: --- Exception Dialog: Radio identification failed. ---
[2019-10-18 10:58:59,467] chirp.ui.inputdialog - ERROR: Traceback (most recent call last):
File "chirpw", line 68, in <module>
AttributeError: 'NoneType' object has no attribute 'split'

[2019-10-18 10:58:59,469] chirp.ui.inputdialog - ERROR: ----------------------------

Updated by Luke Cunnien 8 months ago

My dealership just bought 20 new RT22 (not "S"" model) and Chirp worked flawlessly before.
I have one Walkie that works perfectly (original walkie from when we first bought some). it uploads and downloads but as soon as I connect another walkie (new one) it will give errors and will not download or upload. has anyone found a fix for this yet?

I've uploaded a screen shot of the Data downloaded from the good walkie and then plugged in the new one and tried to upload.

Updated by Vladimir Kondratiev 7 months ago

I have same issue. Have old RT22 that works well while new one failed with "Radio identification failed." debug.log exactly the same as in #3. Ubuntu Linux.

Log fragment:

[2020-01-07 20:55:03,244] chirp.drivers.retevis_rt22 - DEBUG: download
[2020-01-07 20:55:03,292] chirp.drivers.retevis_rt22 - DEBUG: Incorrect model ID, got this:

000: 50 33 32 30 37 21 f8 ff P3207!..

[2020-01-07 20:55:03,293] chirp.ui.reporting - DEBUG: Reporting exception
[2020-01-07 20:55:03,293] chirp.ui.common - ERROR: -- Exception: --
[2020-01-07 20:55:03,293] chirp.ui.common - ERROR: Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/chirp/ui/clone.py", line 256, in run
File "/usr/lib/python2.7/dist-packages/chirp/drivers/retevis_rt22.py", line 331, in sync_in
data = do_download(self)
File "/usr/lib/python2.7/dist-packages/chirp/drivers/retevis_rt22.py", line 230, in do_download
File "/usr/lib/python2.7/dist-packages/chirp/drivers/retevis_rt22.py", line 139, in _rt22_enter_programming_mode
raise errors.RadioError("Radio identification failed.")
RadioError: Radio identification failed.

Updated by Vladimir Kondratiev 7 months ago

I did quick fix by simply adding new ID with hope nothing else changed. I can, at least, read factory settings - see attached. Patch attached as well

Updated by Vladimir Kondratiev 7 months ago

When trying to upload to the new RT22 after fix described in #6, radio ID changed to "\x00\x00\x00\x00\x00\x00\xf8\xff".
If I add this ID as well, it seems to work. On the "settings" page, "Embedded message 1" initially (factory settings) has value "P3207! Pb%FPb%F 0" - it is definitely radio ID is there. After flashing, "Embedded message 1" first 6 characters becomes "\x00". Looks like new RT22 need some more care, this is beyond my abilities

Updated by Bernhard Hailer 3 months ago

  • Tracker changed from New Model to Bug
  • Subject changed from Retevis RT22 New Model "Radio Identification Failed" to Retevis RT22 New firmware "Radio Identification Failed"
  • Target version set to chirp-daily
  • Model affected set to Retevis RT22
  • Platform set to Windows

Has the patch been added since?
You may want to join the developers mailing list, see Wiki, "Developers".

Updated by Bernhard Hailer 3 months ago

Linked half a dozen similar reports for this radio and its variants (WLN KD-C1, Luiton LT-316, etc.).

Updated by Vitaly M 3 months ago

Hi guys, I have the same issue with new Retevis RT22 stations. I have sent a message to Retevis support and wait for their feedback.
Also I had some troubles with Retevis universal USB driver, but downloaded its latest version from chip’s vendor of an adapter (the adapter has produced by Retevis)

Updated by Dan OLeary 2 months ago

In a blatant example of "standing on the shoulders of giants", I changed one character in Mr Kondratiev's patch and was able to read and write to my KD-C1. Specifically, I changed "P32073" to "P3207!" (the patch did not work for me in its original form). I am not at all familiar with Linux so I have to assume I got lucky, but I was willing to sacrifice my radio to test my idea. By loading the altered module, I have been able to read and write successfully more than once. The factory software still can read and write to the radio.

Updated by James Webb 3 days ago

I have also experienced this bug while trying to program a new Retevis RT22 with CHIRP. I am on MacOS 10.15.5 (Catalina) and CHIRP works fine (with my Baofeng UV-5R and other radios). For the Retevis RT22, I got the "Radio Identification Failed" message when trying to Download from Radio. I am not a real developer, but here's what I tried: I downloaded the most recent MacOS version of CHIRP and manually opened up the package. I navigated to the retevis_rt22.py file, opened it up with Text Editor, and made the one change suggested by Mr. OLeary in #11 above. I was then able to download and upload new info to my RT22! So that change seems to be the fix. However, I'm not sure what happened, but now my test copy of CHIRP no longer communicates with my RT22; I'm sure it has something to do with the hacky way I made the change. I hope this patch can be incorporated into the CHIRP baseline soon.

Also available in: Atom PDF

prevent spam